<!doctype html> <html lang=en prefix="og: http://ogp.me/ns#"> <head> <meta charset=utf-8> <meta name=viewport content="width=device-width,initial-scale=1"> <meta name=referrer content=unsafe-url> <meta name=theme-color content=#51EDB9> <meta name=twitter:site content=@romper> <meta property=og:site_name content=Romper> <meta property=fb:app_id content=510210782483125> <link rel=preconnect href=https://cdn.bustle.com crossorigin> <link rel=preconnect href=https://graph.bustle.com crossorigin> <link rel=preconnect href=https://imgix.romper.com crossorigin> <link as="script" rel="preload" href="https://cdn.bustle.com/romper/production/assets/main-47f7963233d2.js"><link as="script" rel="preload" href="https://cdn.bustle.com/romper/production/assets/ArticlePostPage-29114b189619.js"><link as="style" rel="preload" href="https://cdn.bustle.com/romper/production/assets/main-297f257b8374.css"><link as="style" rel="preload" href="https://cdn.bustle.com/romper/production/assets/ArticlePostPage-f2ccffa0d4fd.css"> <link rel=publisher href=https://plus.google.com/110050826057551640071> <link rel="shortcut icon" href=https://cdn.bustle.com/romper/production/public/favicon-20f60b.ico type=image/x-icon> <link rel=apple-touch-icon href=https://cdn.bustle.com/romper/production/public/icon-0d3359.png> <link rel=alternate type=application/rss+xml href=/rss> <link rel="stylesheet" href="https://cdn.bustle.com/romper/production/assets/main-297f257b8374.css"><link rel="stylesheet" href="https://cdn.bustle.com/romper/production/assets/ArticlePostPage-f2ccffa0d4fd.css"> <title>12 Colorful Kids Swimsuits That Scream Pool Party</title><link rel="canonical" href="https://www.romper.com/p/12-colorful-kids-swimsuits-that-scream-pool-party-16981525" /><meta name="description" content="A crazy, colorful swimsuit is something that just about every kid has at some point growing up. For me, it was a bright yellow and blue two piece with huge flowers on it that I wore for two summers in a row in middle school. I felt like I was the…" /><meta name="author" content="Ashley Jones" /><meta property="og:url" content="https://www.romper.com/p/12-colorful-kids-swimsuits-that-scream-pool-party-16981525" /><meta property="og:type" content="article" /><meta property="og:title" content="These Bright Swimsuits For Kids *Scream* Pool Party" /><meta property="og:description" content="A crazy, colorful swimsuit is something that just about every kid has at some point growing up. For me, it was a bright yellow and blue two piece with huge flowers on it that I wore for two summers in a row in middle school. I felt like I was the…" /><meta property="og:image" content="https://imgix.bustle.com/uploads/image/2019/3/25/50d645ed-7999-4d81-a8fc-f43f3ffa2b37-tinydinos_swim_kids_ls_041web_1024x1024.jpg?w=1200&amp;h=630&amp;q=70&amp;fit=crop&amp;crop=faces&amp;fm=jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="630" /><meta name="twitter:card" content="summary_large_image" /><script type="application/ld+json">{"@context":"http://schema.org","@type":"Article","headline":"12 Colorful Kids Swimsuits That Scream Pool Party","description":"A crazy, colorful swimsuit is something that just about every kid has at some point growing up. For me, it was a bright yellow and blue two piece with huge flowers on it that I wore for two summers in a row in middle school. I felt like I was the…","datePublished":"2019-03-25T19:21:08.678Z","dateModified":"2019-03-25T19:21:19.177Z","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.romper.com/p/12-colorful-kids-swimsuits-that-scream-pool-party-16981525"},"image":{"@type":"ImageObject","url":"https://imgix.bustle.com/uploads/image/2019/3/25/50d645ed-7999-4d81-a8fc-f43f3ffa2b37-tinydinos_swim_kids_ls_041web_1024x1024.jpg?w=1200&h=630&q=70&fit=crop&crop=faces&fm=jpg","width":1200,"height":630},"author":{"@type":"Person","name":["Ashley Jones"]},"publisher":{"@type":"Organization","name":"Romper","url":"https://www.romper.com","logo":{"@type":"ImageObject","url":"https://imgix.romper.com/2016/10/1/romper-b72a4876-52a7-46e2-b8a2-6e149dd7d0d4.png","width":186,"height":60}}}</script> </head> <body> <div><header class="cf"><div class="cg"><input id="searchCheckbox" type="checkbox" class="cl" /><label for="navCheckbox" class="ci"><span></span></label><a class="ch" href="/">Romper</a><div class="cj"><div class="ck"><a href="https://www.facebook.com/Romperdotcom/" target="_blank" rel="noopener noreferrer" class="gL"><i class="gM"></i></a><a href="https://twitter.com/romper" target="_blank" rel="noopener noreferrer" class="gL"><i class="gS"></i></a><a href="https://www.pinterest.com/romperdotcom/" target="_blank" rel="noopener noreferrer" class="gL"><i class="gQ"></i></a><a href="https://instagram.com/romper/" target="_blank" rel="noopener noreferrer" class="gL"><i class="gO"></i></a></div><label for="searchCheckbox" class="cm" tabIndex="0"></label></div><form class="co" action="/search" target="_top" autoComplete="off" autoCapitalize="off"><input type="search" placeholder="Search Romper..." aria-label="Search Romper" name="q" class="cp" value /><label for="searchCheckbox" class="cn"></label></form></div></header><div><div class="bp"><article class="C"><div class="fX"><div class="gg"><div class="ht gh"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/50d645ed-7999-4d81-a8fc-f43f3ffa2b37-tinydinos_swim_kids_ls_041web_1024x1024.jpg?w=960&amp;h=540&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/50d645ed-7999-4d81-a8fc-f43f3ffa2b37-tinydinos_swim_kids_ls_041web_1024x1024.jpg?w=480&amp;h=270&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 480w, https://imgix.bustle.com/uploads/image/2019/3/25/50d645ed-7999-4d81-a8fc-f43f3ffa2b37-tinydinos_swim_kids_ls_041web_1024x1024.jpg?w=480&amp;h=270&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 960w, https://imgix.bustle.com/uploads/image/2019/3/25/50d645ed-7999-4d81-a8fc-f43f3ffa2b37-tinydinos_swim_kids_ls_041web_1024x1024.jpg?w=960&amp;h=540&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 1920w" sizes="(min-width:768px) 960px, 480px" alt /></noscript></div><cite class="gC"><a href="https://www.chubbiesshorts.com/products/the-tiny-dinos" target="_blank" rel="noopener noreferrer">Photo courtesy of Chubbies</a></cite></div><div class="gf"><div class="hq"><div id="ad-422"></div></div><h1 class="ge">12 Colorful Kids Swimsuits That Scream Pool Party</h1><div class="fZ"><div class="gE fY"><div class="gU gF"><span>By </span><a href="/profile/ashley-jones-15948999" class="gV" rel="author">Ashley Jones</a></div><time dateTime="2019-03-25T19:21:08.678Z" class="gG">2 hours ago</time></div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.romper.com%2Fp%2F12-colorful-kids-swimsuits-that-scream-pool-party-16981525%3Futm_term%3Dshare" title="Share" class="gH" target="_blank" rel="noopener noreferrer"><i class="gI"></i>Share</a></div></div></div><div class="hq"><div id="ad-423"></div></div><div class="gJ"><div class="gj gK"><p>A crazy, colorful swimsuit is something that just about every kid has at some point growing up. For me, it was a bright yellow and blue two piece with huge flowers on it that I wore for two summers in a row in middle school. I felt like I was the pre-teen queen of every swimming session for those two summers. Luckily, your kids can experience this exact same feeling by choosing one of these <a class href="https://www.speedousa.com/kids" target="_blank" rel="noopener noreferrer">colorful kids swimsuits</a> to rock all summer long. </p><p>Whether they will be splashing in a pool, lounging by a lake, or diving headfirst into ocean waves, these outrageously bright swimsuits are sure to make a splash wherever they go. From funky pineapple prints to color block suits that will give you all the retro vibes you can handle, these suits scream fun. A bright suit is the perfect choice for kids who love to be the center of attention, but is also great for creative kids who just love to have fun with their clothing choices. With options for both boys and girls, this selection is sure to have plenty of options to please choosy kids and parents alike. </p><p>Now, if I could only choose which <a class href="https://www.romper.com/p/14-summer-inflatables-your-backyard-is-going-to-need-this-summer-9413418">giant inflatable sprinkler</a> goes best with my kid's new neon swimsuit, my kids would be totally set for summer fun. </p><div class="go"><h3>1.  Bright Doodles &amp; Funky Colors</h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.childrensplace.com/us/p/Girls-Doodle-Print-Two-Piece-Tankini-Swimsuit-2133744-1600"><span class="iv is"><div class="it" style="padding-top:130.4147%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/7ae20aff-1eff-4114-bf8f-870fcb086149-screen-shot-2019-03-25-at-104405-am.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/7ae20aff-1eff-4114-bf8f-870fcb086149-screen-shot-2019-03-25-at-104405-am.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/7ae20aff-1eff-4114-bf8f-870fcb086149-screen-shot-2019-03-25-at-104405-am.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Girls Doodle Print Two Piece Tankini Swimsuit</span></p><div class="iG"><span class="is"><p class="iB">$9.98</p></span></div><p class="iw"><span class="is">The Children's Place</span></p><span class="is"><button class="ay iC">See on The Children's Place</button></span></div></a><p>This <a class href="https://www.childrensplace.com/us/p/Girls-Doodle-Print-Two-Piece-Tankini-Swimsuit-2133744-1600" target="_blank" rel="noopener noreferrer">tankini-style girls swimsuit</a> from The Children's Place is perfect for girls with an artistic side. The mint green color may look subdued at first glance, but pops of color in the drawings of sunglasses, hearts, and rainbows make this style stand out from the crowd. </p></div></div><div class="go"><h3>2. All Gators All Day</h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.chubbiesshorts.com/products/the-mini-glades-kids?variant=12068273881161&amp;gclid=CjwKCAjw-OHkBRBkEiwAoOZql4rU41rC3qEQVWA39btfWhoNM2p_biHrxhRe5hdgJZqYZxcMcINjkxoCnhEQAvD_BwE"><span class="iv is"><div class="it" style="padding-top:100.0000%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/dae57f0d-3d4c-4527-94fe-39d2d8cda775-miniglades_swim_kids_front_1024x1024.jpg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/dae57f0d-3d4c-4527-94fe-39d2d8cda775-miniglades_swim_kids_front_1024x1024.jpg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/dae57f0d-3d4c-4527-94fe-39d2d8cda775-miniglades_swim_kids_front_1024x1024.jpg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">The Mini Glades</span></p><div class="iG"><span class="is"><p class="iB">$44.50</p></span></div><p class="iw"><span class="is">Chubbies</span></p><span class="is"><button class="ay iC">See on Chubbies</button></span></div></a><p>Chubbies carries so many brightly colored swimsuits that it's hard to choose which one will best suit kids who want to make a splash at their next pool party. But these <a class href="https://www.chubbiesshorts.com/products/the-mini-glades-kids?variant=12068273881161&amp;gclid=CjwKCAjw-OHkBRBkEiwAoOZql4rU41rC3qEQVWA39btfWhoNM2p_biHrxhRe5hdgJZqYZxcMcINjkxoCnhEQAvD_BwE" target="_blank" rel="noopener noreferrer">adorable alligator swim trunks</a> are just too cute to pass up. The bright pink background and teal alligators are a splashingly bright combination that is sure to please any fun-loving kid. </p></div></div><div class="go"><h3>3. Tropical Vibes </h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.shopjustice.com/tropical-flutter-bikini-/prd-15810007#color/643"><span class="iv is"><div class="it" style="padding-top:144.3515%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/e8787000-2e5f-4415-8536-a7babe361beb-15810007_643_plus.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/e8787000-2e5f-4415-8536-a7babe361beb-15810007_643_plus.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/e8787000-2e5f-4415-8536-a7babe361beb-15810007_643_plus.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Tropical Flutter Bikini</span></p><div class="iG"><span class="is"><p class="iB">$34.90</p></span></div><p class="iw"><span class="is">Justice</span></p><span class="is"><button class="ay iC">See on Justice</button></span></div></a><p>My go-to when <a class href="https://www.shopjustice.com/tropical-flutter-bikini-/prd-15810007#color/643" target="_blank" rel="noopener noreferrer">shopping for bright swimsuits</a> for my stepdaughter is Justice. I can personally attest to the ridiculous brightness of their suits holding up to lots of time in the sun and plenty of washes. I also love that they have inclusive sizing.</p></div></div><div class="go"><h3>4. Birds Of A Feather Swim Together</h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.target.com/p/boys-swim-trunks-cat-jack-153-white/-/A-53465374?preselect=53460055#lnk=sametab"><span class="iv is"><div class="it" style="padding-top:100.0000%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/9e908e60-0064-429e-ab8d-6081b19f8b62-guest_2127f724-b6f9-4168-94e9-e34e5e7cff58.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/9e908e60-0064-429e-ab8d-6081b19f8b62-guest_2127f724-b6f9-4168-94e9-e34e5e7cff58.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/9e908e60-0064-429e-ab8d-6081b19f8b62-guest_2127f724-b6f9-4168-94e9-e34e5e7cff58.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Boys' Swim Trunks - Cat &amp; Jack™ White</span></p><div class="iG"><span class="is"><p class="iB">$12.99</p></span></div><p class="iw"><span class="is">Target</span></p><span class="is"><button class="ay iC">See on Target</button></span></div></a><p>If you're going to be shopping at Target anyway, you might as well pick up a pair of these <a class href="https://www.target.com/p/boys-swim-trunks-cat-jack-153-white/-/A-53465374?preselect=53460055#lnk=sametab" target="_blank" rel="noopener noreferrer">funky boys swim trunks</a> while you're there. Bright green, blue, red, and yellow birds with feathers pluming stand out against the bright white background of these totally cool board short-style swim trunks.  </p></div></div><div class="go"><h3>5. Watermelon Daze</h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.target.com/p/girls-one-in-melon-one-piece-with-skirt-swimsuit-cat-jack-153-coral/-/A-53759759?preselect=53731675#lnk=sametab"><span class="iv is"><div class="it" style="padding-top:100.0000%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/0418a918-4407-4919-ad01-ffe44b8d57aa-guest_e75df88f-84d7-4e4b-a27d-5f4ebb79b9da.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/0418a918-4407-4919-ad01-ffe44b8d57aa-guest_e75df88f-84d7-4e4b-a27d-5f4ebb79b9da.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/0418a918-4407-4919-ad01-ffe44b8d57aa-guest_e75df88f-84d7-4e4b-a27d-5f4ebb79b9da.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Girls' One in Melon One Piece with Skirt Swimsuit - Cat &amp; Jack™ Coral</span></p><div class="iG"><span class="is"><p class="iB">$19.99</p></span></div><p class="iw"><span class="is">Target</span></p><span class="is"><button class="ay iC">See on Target</button></span></div></a><p>Another amazing Target find is this <a class href="https://www.target.com/p/girls-one-in-melon-one-piece-with-skirt-swimsuit-cat-jack-153-coral/-/A-53759759?preselect=53731675#lnk=sametab" target="_blank" rel="noopener noreferrer">super bright watermelon swimsuit for girls</a>. (Um, hi, does this come in adult sizes so that I can wear one, too?)  The removable neon green ruffle swim skirt is the stuff childhood dreams are made of. </p></div></div><div class="go"><h3>6. Dino-mite Swim Trunks</h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.chubbiesshorts.com/products/the-tiny-dinos"><span class="iv is"><div class="it" style="padding-top:100.0000%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/0e9ca67b-5aac-4265-88e1-dc71945e86c3-tinydinos_swim_kids_front_1024x1024.jpg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/0e9ca67b-5aac-4265-88e1-dc71945e86c3-tinydinos_swim_kids_front_1024x1024.jpg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/0e9ca67b-5aac-4265-88e1-dc71945e86c3-tinydinos_swim_kids_front_1024x1024.jpg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">The Tiny Dinos</span></p><div class="iG"><span class="is"><p class="iB">$44.50</p></span></div><p class="iw"><span class="is">Chubbies</span></p><span class="is"></span></div></a><p>I may or may not have already ordered these <a class href="https://www.chubbiesshorts.com/products/the-tiny-dinos" target="_blank" rel="noopener noreferrer">ridiculously fun dinosaur swim trunks</a> from Chubbies for my son. The bright purple background with bright blue retro shapes and doodles feature neon orange dinosaurs that absolutely pop. These funky swim shorts are perfect for all of the sprinkler running and slip-n-slide action your kids can handle. </p></div></div><div class="go"><h3>7. Metallic Mayhem</h3><div class="gj"><p></p><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.shopjustice.com/metallic-shimmer-one-piece-/prd-15800544#color/622"><span class="iv is"><div class="it" style="padding-top:144.3515%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/1d305552-b202-4334-a6d7-b087972d801b-15800544_622_plus.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/1d305552-b202-4334-a6d7-b087972d801b-15800544_622_plus.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/1d305552-b202-4334-a6d7-b087972d801b-15800544_622_plus.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Metallic Shimmer One Piece</span></p><div class="iG"><span class="is"><p class="iB">$34.90</p></span></div><p class="iw"><span class="is">Justice</span></p><span class="is"><button class="ay iC">See on Justice</button></span></div></a><p>This bright and shiny <a class href="https://www.shopjustice.com/metallic-shimmer-one-piece-/prd-15800544#color/622" target="_blank" rel="noopener noreferrer">metallic one piece swimsuit</a> from Justice is perfect for girls who want to stand out in a crowd. The shimmer effect that the metallic fabric creates is perfect for wearing to any beach or pool in the summer sun. </p></div></div><div class="go"><h3>8. Go Go Geometric </h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.zulily.com/p_/lime-geometric-board-shorts-boys-5675-54513193.html?rtn=y&amp;page=pdp&amp;hpd=r&amp;ref=hybrid_pdp"><span class="iv is"><div class="it" style="padding-top:92.0082%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/1e3ccffd-b383-47b3-91cb-d027be3b6456-screen-shot-2019-03-25-at-115215-am.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/1e3ccffd-b383-47b3-91cb-d027be3b6456-screen-shot-2019-03-25-at-115215-am.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/1e3ccffd-b383-47b3-91cb-d027be3b6456-screen-shot-2019-03-25-at-115215-am.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Lime Geometric Board Shorts</span></p><div class="iG"><span class="is"><p class="iB">$12.99</p></span></div><p class="iw"><span class="is">Zulily</span></p><span class="is"><button class="ay iC">See on Zulily</button></span></div></a><p>Boys can make a splash in these <a class href="https://www.zulily.com/p_/lime-geometric-board-shorts-boys-5675-54513193.html?rtn=y&amp;page=pdp&amp;hpd=r&amp;ref=hybrid_pdp" target="_blank" rel="noopener noreferrer">neon green board shorts</a> by Sketchers. The funky geometric design is giving me so many 80s vibes, I can barely stand it, and the black color block on the bottom of the shorts really helps offset the brightness of the neon green. </p></div></div><div class="go"><h3>9. Fun With Flamingoes </h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.shopjustice.com/flamingo-one-shoulder-one-piece/prd-15800160#color/683"><span class="iv is"><div class="it" style="padding-top:144.3515%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/6e15d668-1fde-4df7-869a-8809ab4ff967-15800160_683.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/6e15d668-1fde-4df7-869a-8809ab4ff967-15800160_683.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/6e15d668-1fde-4df7-869a-8809ab4ff967-15800160_683.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Flamingo One Shoulder One Piece</span></p><div class="iG"><span class="is"><p class="iB">$34.90</p></span></div><p class="iw"><span class="is">Justice</span></p><span class="is"><button class="ay iC">See on Justice</button></span></div></a><p>Flamingoes are such a summer staple that they have become commonplace in swimwear design. But this <a class href="https://www.shopjustice.com/flamingo-one-shoulder-one-piece/prd-15800160#color/683" target="_blank" rel="noopener noreferrer">bright and splashy one piece girls swimsuit</a> design by Justice is anything but commonplace. The solid teal color is just dreamy and the bright pink flamingo and pink strap detailing really pop. </p></div></div><div class="go"><h3>10. Sporty Color Fade </h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.dickssportinggoods.com/p/under-armour-boys-fader-2-0-volley-swim-trunks-18uaryfdr20vllyxxbal/18uaryfdr20vllyxxbal"><span class="iv is"><div class="it" style="padding-top:185.0000%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/e1f8d48d-fa42-4b8e-9e31-850557cbfbdc-18uaryfdr20vllyxxbal_ultra_blue.jpeg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/e1f8d48d-fa42-4b8e-9e31-850557cbfbdc-18uaryfdr20vllyxxbal_ultra_blue.jpeg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/e1f8d48d-fa42-4b8e-9e31-850557cbfbdc-18uaryfdr20vllyxxbal_ultra_blue.jpeg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Under Armour Boys' Fader 2.0 Volley Swim Trunks</span></p><div class="iG"><span class="is"><p class="iB">$38</p></span></div><p class="iw"><span class="is">Dick's Sporting Goods</span></p><span class="is"><button class="ay iC">See on Dick's Sporting Goods</button></span></div></a><p>Don't be fooled by the words &quot;color fade&quot; because the color on these <a class href="https://www.dickssportinggoods.com/p/under-armour-boys-fader-2-0-volley-swim-trunks-18uaryfdr20vllyxxbal/18uaryfdr20vllyxxbal" target="_blank" rel="noopener noreferrer">Under Armour boys swim trunks</a> at Dick's Sporting Goods is so bright, you might need to throw on a pair of shades when looking at them. The neon green and bright blue design of these trunks is sure to make a splash this summer. </p></div></div><div class="go"><h3>11. Magical Sequined Unicorn</h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.target.com/p/girls-flip-sequins-time-to-shine-one-piece-swimsuit-cat-jack-153/-/A-54189229?preselect=54031638#lnk=sametab"><span class="iv is"><div class="it" style="padding-top:100.0000%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/431b1aba-25bc-45ea-8f5c-b6ce4d5e9a9b-guest_1f18242b-0506-41dd-84c4-ba0cebaa9cb6.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/431b1aba-25bc-45ea-8f5c-b6ce4d5e9a9b-guest_1f18242b-0506-41dd-84c4-ba0cebaa9cb6.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/431b1aba-25bc-45ea-8f5c-b6ce4d5e9a9b-guest_1f18242b-0506-41dd-84c4-ba0cebaa9cb6.webp?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Girls' Flip Sequins Time to Shine One Piece Swimsuit - Cat &amp; Jack™</span></p><div class="iG"><span class="is"><p class="iB">$16.99</p></span></div><p class="iw"><span class="is">Target</span></p><span class="is"><button class="ay iC">See on Target</button></span></div></a><p>Would this really be an article about kids swimsuits without at least one <a class href="https://www.target.com/p/girls-flip-sequins-time-to-shine-one-piece-swimsuit-cat-jack-153/-/A-54189229?preselect=54031638#lnk=sametab" target="_blank" rel="noopener noreferrer">girls unicorn swimsuit</a>? This unicorn swimsuit is so magical, it even has shimmery sequins and rainbow stripes. No doubt about it, this one is as bright and shiny as any girl could want.</p></div></div><div class="go"><h3>12. Pineapple Surprise</h3><div class="gj"><a class="ir iJ" target="_blank" rel="noopener noreferrer" href="https://www.abercrombie.com/shop/us/kids/p/logo-boardshorts-15963331?seq=10&amp;source=googleshopping&amp;source=googleshopping&amp;country=US&amp;cmp=PLA_G_SC+Shopping+-+afk+-+Desktop_All+Products_PRODUCT_GROUP&amp;gclid=CjwKCAjw-OHkBRBkEiwAoOZqlxfQWKG9wj_XYowtQfP3fnzSJQmwh4buP92Z_F4IeNAgs6S5Qxv4NRoCRn0QAvD_BwE&amp;gclsrc=aw.ds"><span class="iv is"><div class="it" style="padding-top:125.0000%"><div class="ht"><noscript><img src="https://imgix.bustle.com/uploads/image/2019/3/25/948d4cf5-f7b7-4f39-865d-0688c86e9790-kic_233-9001-0195-088_prod1.jpeg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2019/3/25/948d4cf5-f7b7-4f39-865d-0688c86e9790-kic_233-9001-0195-088_prod1.jpeg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2019/3/25/948d4cf5-f7b7-4f39-865d-0688c86e9790-kic_233-9001-0195-088_prod1.jpeg?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format&amp;q=70&amp;dpr=2 828w" sizes="(min-width:768px) 414px, 414px" alt /></noscript></div></div></span><div class="iu"><p class="iz"><span class="is">Tropical Boardshorts For Boys</span></p><div class="iG"><span class="is"><p class="iB">$29.95</p></span></div><p class="iw"><span class="is">Abercrombie and Fitch</span></p><span class="is"><button class="ay iC">See on Amazon</button></span></div></a><p>Who lives in a pineapple under the sea? Well, it could be your kid when he sports these <a class href="https://www.abercrombie.com/shop/us/kids/p/logo-boardshorts-15963331?seq=10&amp;source=googleshopping&amp;source=googleshopping&amp;country=US&amp;cmp=PLA_G_SC+Shopping+-+afk+-+Desktop_All+Products_PRODUCT_GROUP&amp;gclid=CjwKCAjw-OHkBRBkEiwAoOZqlxfQWKG9wj_XYowtQfP3fnzSJQmwh4buP92Z_F4IeNAgs6S5Qxv4NRoCRn0QAvD_BwE&amp;gclsrc=aw.ds" target="_blank" rel="noopener noreferrer">bright yellow swim trunks</a> from Abercrombie and Fitch all summer long. The bright blue pineapples are so whimsical and fun that your kid won't be able to stand not wearing these board shorts to every single pool party they're invited to. </p></div></div></div></div></article><div class="bq"></div></div></div><div class="cq"><input id="navCheckbox" type="checkbox" class="ct" /><label for="navCheckbox" class="cr"></label><nav class="cs"><ul class="cu"><li class="cv"><a href="/pregnancy">Pregnancy</a></li><li class="cv"><a href="/motherhood">Motherhood</a></li><li class="cv"><a href="/baby">Baby</a></li><li class="cv"><a href="/toddler">Toddler</a></li><li class="cv"><a href="/kid">Kid</a></li><li class="cv"><a href="/food">Food</a></li><li class="cv"><a href="/news">News</a></li><li class="cv"><a href="/entertainment">Entertainment</a></li><li class="cv"><a href="/sex-relationships">Sex &amp; Relationships</a></li><li class="cv"><a href="/fashion-beauty">Fashion &amp; Beauty</a></li><li><div class="cw"></div></li><li><a href="https://bustle.company/" target="_blank" rel="noopener noreferrer">About Us</a></li><li><a href="/contact">Contact</a></li><li><a href="/newsletter">Newsletter</a></li><li><a href="/terms">Terms</a></li><li><a href="/privacy">Privacy</a></li><li><div class="cx"><a href="https://www.facebook.com/Romperdotcom/" target="_blank" rel="noopener noreferrer" class="gL"><i class="gM"></i></a><a href="https://twitter.com/romper" target="_blank" rel="noopener noreferrer" class="gL"><i class="gS"></i></a><a href="https://www.pinterest.com/romperdotcom/" target="_blank" rel="noopener noreferrer" class="gL"><i class="gQ"></i></a><a href="https://instagram.com/romper/" target="_blank" rel="noopener noreferrer" class="gL"><i class="gO"></i></a></div></li></ul><label for="navCheckbox" class="cy"></label></nav></div><noscript><img src="https://pixel.quantserve.com/pixel/p-xPmcrFNGfHkBg.gif" /><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=17519299&amp;cs_ucfr=0&amp;cv=2.0&amp;cj=1" /><img src="https://www.facebook.com/tr?id=932972280084675&amp;ev=PageView&amp;noscript=1" /></noscript></div> <script>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</script> <script>!(function (){for(var t=["Promise","fetch","Map","Object.assign"],e=0,n=t.length;e<n;e++){var r=t[e].split("."),i=window[r[0]];if(!i||r.length>1&&!i[r[1]])return document.write('<script defer src="https://cdn.bustle.com/misc/polyfills-030818.js"><\/script>')}}());</script> <script defer src="https://cdn.bustle.com/romper/production/assets/main-47f7963233d2.js"></script><script defer src="https://cdn.bustle.com/romper/production/assets/ArticlePostPage-29114b189619.js"></script> </body> </html> 