<!doctype html><html lang="en" prefix="og: http://ogp.me/ns#"><head><meta charset="utf-8" /><meta name="viewport" content="width=device-width,initial-scale=1" /><meta name="referrer" content="unsafe-url" /><meta name="twitter:site" content="@romper" /><meta property="og:site_name" content="Romper" /><meta property="fb:app_id" content="510210782483125" /><meta name="p:domain_verify" content="8b71f73a52fcf8a6f9961cd2f3e39ffa" /><link rel="icon" id="favicon" type="image/x-icon" href="https://cdn2.bustle.com/romper/2020/favicon-debd6ab8f3.ico" /><link rel="apple-touch-icon" href="https://cdn2.bustle.com/romper/2020/icon-fb7a00fd64.png" /><link rel="alternate" type="application/rss+xml" href="/rss" /><link rel="preconnect" href="https://cdn2.bustle.com" crossorigin /><link rel="preconnect" href="https://graph.bustle.com" crossorigin /><link rel="preconnect" href="https://use.typekit.net" crossorigin /><link rel="preload" as="script" href="https://cdn2.bustle.com/romper/2020/common-31a289e806.js" /><link rel="preload" as="script" href="https://cdn2.bustle.com/romper/2020/main-6c6ae4e123.js" /><link rel="preload" as="script" href="https://cdn2.bustle.com/romper/2020/vendors-78bded0d9b.js" /><link rel="preload" as="script" href="https://cdn2.bustle.com/romper/2020/ArticlePostPage-8b1a904f6c.js" /><link rel="stylesheet" href="https://cdn2.bustle.com/romper/2020/common-cb970e28ed.css" /><link rel="stylesheet" href="https://cdn2.bustle.com/romper/2020/ArticlePostPage-a0c3784a27.css" /><link rel="stylesheet" href="https://use.typekit.net/pmi7ejb.css" /><title>Old Navy's Memorial Day Sale Includes 50% Off All Swimwear &amp; So Much More</title><link rel="canonical" href="https://www.romper.com/p/old-navys-memorial-day-sale-includes-50-off-all-swimwear-so-much-more-22920760" /><meta name="description" content="This Memorial Day might be missing the usual crowded beach hangs and neighborhood BBQs, but one thing's still the same — the unbeatable sales. Old Navy's Memorial Day sale is no exception, and you'll find so much more than flag tees (though,…" /><meta property="og:url" content="https://www.romper.com/p/old-navys-memorial-day-sale-includes-50-off-all-swimwear-so-much-more-22920760" /><meta property="og:type" content="article" /><meta property="og:title" content="Stock Up On $6 Shorts &amp; So Much More At Old Navy's Memorial Day Sale" /><meta property="og:description" content="This Memorial Day might be missing the usual crowded beach hangs and neighborhood BBQs, but one thing's still the same — the unbeatable sales. Old Navy's Memorial Day sale is no exception, and you'll find so much more than flag tees (though,…" /><meta property="og:image" content="https://imgix.bustle.com/uploads/image/2020/5/20/d0f44bf4-e824-4321-8cf1-8ca60ff66d4f-screen-shot-2020-05-20-at-15109-pm.png?w=1200&amp;h=630&amp;q=70&amp;fit=crop&amp;crop=faces&amp;fm=jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="630" /><meta name="twitter:card" content="summary_large_image" /><script type="application/ld+json">[{"@type":"Article","@context":"http://schema.org","headline":"Old Navy's Memorial Day Sale Includes 50% Off All Swimwear & So Much More","description":"This Memorial Day might be missing the usual crowded beach hangs and neighborhood BBQs, but one thing's still the same — the unbeatable sales. Old Navy's Memorial Day sale is no exception, and you'll find so much more than flag tees (though,…","datePublished":"2020-05-21T14:26:06.984Z","dateModified":"2020-05-21T14:26:06.984Z","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.romper.com/p/old-navys-memorial-day-sale-includes-50-off-all-swimwear-so-much-more-22920760"},"image":{"@type":"ImageObject","url":"https://imgix.bustle.com/uploads/image/2020/5/20/d0f44bf4-e824-4321-8cf1-8ca60ff66d4f-screen-shot-2020-05-20-at-15109-pm.png?w=1200&h=630&q=70&fit=crop&crop=faces&fm=jpg","width":1200,"height":630},"author":[{"@type":"Person","name":"Grace Gallagher","url":"https://www.romper.com/profile/grace-gallagher-16096680"}],"publisher":{"@type":"Organization","name":"Romper","url":"https://www.romper.com","logo":{"@type":"ImageObject","url":"https://cdn2.bustle.com/romper/2020/logo-sdata-f587b17a2b.png","width":186,"height":60}},"articleSection":"Lifestyle","creator":["Grace Gallagher"],"keywords":["Fashion","Shopping","Holidays","lifestyle","homepage","fashion","shopping","holidays"]},{"@context":"http://schema.org","@graph":[{"@type":"BreadcrumbList","itemListElement":{"@type":"ListItem","position":0,"name":"Lifestyle","item":"https://www.romper.com/lifestyle"}}]}]</script></head><body><div><header class="qpa"><div class="zAh"><input id="searchCheckbox" type="checkbox" class="fzc" /><label for="navCheckbox" class="aCt"><span></span><button aria-label="Menu" aria-haspopup="true" aria-expanded="false" class="uYO"></button></label><a class="OLZ" href="/">Romper</a><div class="adw"><div class="WiE"><a href="https://www.facebook.com/Romperdotcom/" title="Facebook" target="_blank" rel="noopener noreferrer" class="eaq"><i class="MQj"></i></a><a href="https://twitter.com/romper" title="Twitter" target="_blank" rel="noopener noreferrer" class="eaq"><i class="PGz"></i></a><a href="https://www.pinterest.com/romperdotcom/" title="Pinterest" target="_blank" rel="noopener noreferrer" class="eaq"><i class="JNN"></i></a><a href="https://instagram.com/romper/" title="Instagram" target="_blank" rel="noopener noreferrer" class="eaq"><i class="wWk"></i></a></div><label for="searchCheckbox" class="mbN"><button class="uYO" aria-label="Search Romper"></button></label></div><form class="Wqc" action="/search" target="_top" autoComplete="off" autoCapitalize="off"><input type="search" placeholder="Search Romper..." aria-label="Search Romper" name="q" class="OnA" value /><label for="searchCheckbox" class="gNn"><button type="button" class="uYO" aria-label="Close search"></button></label></form></div></header><div><article class="Bro"><div class="tlG"><div class="vog"><div class="eZr dVN"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/d0f44bf4-e824-4321-8cf1-8ca60ff66d4f-screen-shot-2020-05-20-at-15109-pm.png?w=960&amp;h=540&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/d0f44bf4-e824-4321-8cf1-8ca60ff66d4f-screen-shot-2020-05-20-at-15109-pm.png?w=480&amp;h=270&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 480w, https://imgix.bustle.com/uploads/image/2020/5/20/d0f44bf4-e824-4321-8cf1-8ca60ff66d4f-screen-shot-2020-05-20-at-15109-pm.png?w=480&amp;h=270&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 960w, https://imgix.bustle.com/uploads/image/2020/5/20/d0f44bf4-e824-4321-8cf1-8ca60ff66d4f-screen-shot-2020-05-20-at-15109-pm.png?w=960&amp;h=540&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 1920w" sizes="(min-width:768px) 960px, 480px" alt="4 women in Old Navy bathing suits" class="Eds dny" /></noscript></div><cite class><a href="https://oldnavy.gap.com/" target="_blank" rel="noopener noreferrer">Old Navy</a></cite></div><div class="aPe"><h1 class="Xwq">Old Navy's Memorial Day Sale Includes 50% Off All Swimwear &amp; So Much More</h1><div class="Rfu"><div class="QBc CGb"><div class="laD FNv byline"><span>By </span><a href="/profile/grace-gallagher-16096680" class="Neu">Grace Gallagher</a></div><div class="KET"><time dateTime="2020-05-21T14:26:06.984Z">May 21, 2020</time></div></div><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.romper.com%2Fp%2Fold-navys-memorial-day-sale-includes-50-off-all-swimwear-so-much-more-22920760%3Futm_term%3Dshare" title="Share" class="twy ADW" target="_blank" rel="noopener noreferrer"><i class="gz_"></i>Share</a></div></div></div><div class="Ccq"><div data-adroot class="ykW Zku"><p>This Memorial Day might be missing the usual crowded beach hangs and neighborhood BBQs, but one thing's still the same — the unbeatable sales. <a class href="https://oldnavy.gap.com/" target="_blank" rel="noopener noreferrer">Old Navy's Memorial Day</a><strong> </strong>sale is no exception, and you'll find so much more than flag tees (though, reliably, you'll find those too). </p><p>If your kids have outgrown every single article of clothing they wore last summer, don't stress. Old Navy is offering 50% off all shorts, tees, tanks, and swim for everyone in your family. Since they're already known for their reasonable prices, when you take a full 50% off their costs, it means you can stock up (like really, <em>stock up</em>) on summer staples for your crew without breaking the bank. </p><p>From <a class href="https://www.romper.com/p/10-summer-maternity-staples-under-40-to-keep-your-closet-stocked-22762086">maternity styles</a> and plus-size bathing suits to comfy shorts for kids and soft t-shirts dads will live in, there's something for everyone. You can start your shopping now, too, because the sale runs from May 20 to May 29, giving you more than a week to grab your essentials (and, um, not necessarily <em>essentials </em>but one-of-a-kind items like a graphic tee featuring a unicorn wearing American flag sunglasses). Whether you need a stash of basics that you can layer all year or a one-time <a class href="https://www.romper.com/p/carters-memorial-day-sale-is-here-tons-of-summer-essentials-are-50-off-22919143">July 4th look for your little one</a>, you'll find it at the Old Navy Memorial Day sale.</p><div class="FtN"><h3>1. A Rashguard For Kids</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=553521012#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/e8e354e0-811d-46e2-b71f-4e456c58389b-screen-shot-2020-05-20-at-122542-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/e8e354e0-811d-46e2-b71f-4e456c58389b-screen-shot-2020-05-20-at-122542-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/e8e354e0-811d-46e2-b71f-4e456c58389b-screen-shot-2020-05-20-at-122542-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/e8e354e0-811d-46e2-b71f-4e456c58389b-screen-shot-2020-05-20-at-122542-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/e8e354e0-811d-46e2-b71f-4e456c58389b-screen-shot-2020-05-20-at-122542-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Printed Zip-Front Rashguard Swimsuit </div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$23</div><div class="BmB">$11</div></div></div><p class="MDt">Available In Sizes 12-18M - 5T</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>Tye-die is having a major moment this summer, and this rashguard swimsuit is giving me rainbow sherbert vibes. It has built-in UPF 50 sun protection (but don't forget to still slather on the SPF) and it's also available in a <a class href="https://oldnavy.gap.com/browse/product.do?pid=553521012#pdp-page-content" target="_blank" rel="noopener noreferrer">pretty floral print</a>.</p></div></div><div class="FtN"><h3>2. Colorful Shorts</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=552720002#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/216b668c-abf5-483e-97a1-3c6e6be4b082-screen-shot-2020-05-20-at-122848-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/216b668c-abf5-483e-97a1-3c6e6be4b082-screen-shot-2020-05-20-at-122848-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/216b668c-abf5-483e-97a1-3c6e6be4b082-screen-shot-2020-05-20-at-122848-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/216b668c-abf5-483e-97a1-3c6e6be4b082-screen-shot-2020-05-20-at-122848-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/216b668c-abf5-483e-97a1-3c6e6be4b082-screen-shot-2020-05-20-at-122848-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Mid-Rise Distressed Pop-Color Jean Shorts</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$30</div><div class="BmB">$15</div></div></div><p class="MDt">Available In Sizes 0-18</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>The classic jean short (aka jort) gets an unexpected twist with this peachy color. The 50-inch inseam is long enough to wear comfortably, and the rips give the soft color a little edge.</p></div></div><div class="FtN"><h3>3. A Retro Tee</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=551067082#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/78aefeb1-5b54-403e-9cce-385bb6bd97f6-screen-shot-2020-05-20-at-123416-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/78aefeb1-5b54-403e-9cce-385bb6bd97f6-screen-shot-2020-05-20-at-123416-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/78aefeb1-5b54-403e-9cce-385bb6bd97f6-screen-shot-2020-05-20-at-123416-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/78aefeb1-5b54-403e-9cce-385bb6bd97f6-screen-shot-2020-05-20-at-123416-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/78aefeb1-5b54-403e-9cce-385bb6bd97f6-screen-shot-2020-05-20-at-123416-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Soft-Washed Embroidered-Graphic Tee</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$15</div><div class="BmB">$8</div></div></div><p class="MDt">Available In Sizes S-XL</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>Perfect for the dad who's nostalgic for mix tapes, this classic tee gets a little twist with the embroidered cassette tape peeking out of the pocket. The jersey knit is buttery and soft, plus the shirt is tag-free for a smooth, comfy fit. This is also available with an embroidered cactus or toucan.</p></div></div><div class="FtN"><h3>4. Comfy Shorts</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=552235022&amp;pcid=999&amp;vid=1&amp;searchText=boys+shorts#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/b28ed012-4673-49af-b59c-3d1bd8627871-screen-shot-2020-05-20-at-123924-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/b28ed012-4673-49af-b59c-3d1bd8627871-screen-shot-2020-05-20-at-123924-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/b28ed012-4673-49af-b59c-3d1bd8627871-screen-shot-2020-05-20-at-123924-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/b28ed012-4673-49af-b59c-3d1bd8627871-screen-shot-2020-05-20-at-123924-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/b28ed012-4673-49af-b59c-3d1bd8627871-screen-shot-2020-05-20-at-123924-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">French Terry Jogger Shorts For Kids</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$13</div><div class="BmB">$6</div></div></div><p class="MDt">Available In Sizes XS-XL</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>You won't hear any complaints when it comes time for your kiddo to pull these shorts on. They're as comfy as sweat pants while still being warm weather-friendly, plus they come in seven colors, which means you can buy the whole set for $42.</p></div></div><div class="FtN"><h3>5. A Retro-Inspired One Piece</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=588315002#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/938ec445-1c39-4bde-b24d-e3f8400639d6-screen-shot-2020-05-20-at-125207-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/938ec445-1c39-4bde-b24d-e3f8400639d6-screen-shot-2020-05-20-at-125207-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/938ec445-1c39-4bde-b24d-e3f8400639d6-screen-shot-2020-05-20-at-125207-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/938ec445-1c39-4bde-b24d-e3f8400639d6-screen-shot-2020-05-20-at-125207-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/938ec445-1c39-4bde-b24d-e3f8400639d6-screen-shot-2020-05-20-at-125207-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Wrap-Front Plus-Size One-Piece Swimsuit</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$60</div><div class="BmB">$30</div></div></div><p class="MDt">Available In Sizes 1X-4X</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>Finally, a one-piece bathing suit that's not blah and won't break the bank. This retro-ish cheerful stripe brightens up any pool, and the underwire gives plenty of support. The adjustable straps can be criss-crossed or worn cami style.</p></div></div><div class="FtN"><h3>6. A Funky Graphic Tee</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=572671022#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/bf04c772-0e03-42bf-a4c9-9e7f5f54477e-screen-shot-2020-05-20-at-125542-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/bf04c772-0e03-42bf-a4c9-9e7f5f54477e-screen-shot-2020-05-20-at-125542-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/bf04c772-0e03-42bf-a4c9-9e7f5f54477e-screen-shot-2020-05-20-at-125542-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/bf04c772-0e03-42bf-a4c9-9e7f5f54477e-screen-shot-2020-05-20-at-125542-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/bf04c772-0e03-42bf-a4c9-9e7f5f54477e-screen-shot-2020-05-20-at-125542-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Graphic Split-Back Tee for Girls</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$17</div><div class="BmB">$8</div></div></div><p class="MDt">Available In Sizes XS-XXL</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>There's nothing like a patriotic unicorn to really lighten the mood. The funky graphic tee gets some extra flair with a small split up the back. The same style is also available with a glittery heart or a melty, sparkly ice cream cone graphic.</p></div></div><div class="FtN"><h3>7. A Maternity Bathing Top</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=588538002#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/f06783e5-b814-4d97-8fe9-cf1af93f96b0-screen-shot-2020-05-20-at-10134-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/f06783e5-b814-4d97-8fe9-cf1af93f96b0-screen-shot-2020-05-20-at-10134-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/f06783e5-b814-4d97-8fe9-cf1af93f96b0-screen-shot-2020-05-20-at-10134-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/f06783e5-b814-4d97-8fe9-cf1af93f96b0-screen-shot-2020-05-20-at-10134-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/f06783e5-b814-4d97-8fe9-cf1af93f96b0-screen-shot-2020-05-20-at-10134-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Maternity Floral-Print Halter Tankini Swim Top</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$37</div><div class="BmB">$19</div></div></div><p class="MDt">Available In XS-XXL</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>If you're pregnant in the scorching summer months, you're going to want to lounge in a cold body of water as much as possible. Bump-friendly swimwear doesn't have to be basic black (though this style <em>is</em> available in the classic shade). There's a <a class href="https://oldnavy.gap.com/browse/product.do?pid=588503002#pdp-page-content" target="_blank" rel="noopener noreferrer">matching high-waisted bottom</a> available, or mix and match with something you already own.</p></div></div><div class="FtN"><h3>8. A Trio Of Tanks</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=573265012#pdp-page-content"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/131ecda4-1e90-4e2d-9105-3da79fe9c557-screen-shot-2020-05-20-at-10623-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/131ecda4-1e90-4e2d-9105-3da79fe9c557-screen-shot-2020-05-20-at-10623-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/131ecda4-1e90-4e2d-9105-3da79fe9c557-screen-shot-2020-05-20-at-10623-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/131ecda4-1e90-4e2d-9105-3da79fe9c557-screen-shot-2020-05-20-at-10623-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/131ecda4-1e90-4e2d-9105-3da79fe9c557-screen-shot-2020-05-20-at-10623-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Jersey Tank Top 3-Pack</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$25</div><div class="BmB">$12</div></div></div><p class="MDt">Available In Sizes 12-18M - 5T</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>Can your kiddo really ever have too many tanks? No, especially when they come to $4 a piece. These summery tanks are giving off major rocket ship popsicle vibes.</p></div></div><div class="FtN"><h3>9. Classic Khakis</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=553229012"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/181c218d-8405-45fc-8cc6-8c97797c3502-screen-shot-2020-05-20-at-11142-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/181c218d-8405-45fc-8cc6-8c97797c3502-screen-shot-2020-05-20-at-11142-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/181c218d-8405-45fc-8cc6-8c97797c3502-screen-shot-2020-05-20-at-11142-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/181c218d-8405-45fc-8cc6-8c97797c3502-screen-shot-2020-05-20-at-11142-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/181c218d-8405-45fc-8cc6-8c97797c3502-screen-shot-2020-05-20-at-11142-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Lived-In Straight Khaki Shorts</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$25</div><div class="BmB">$12</div></div></div><p class="MDt">Available In Sizes 28W-42W</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>These are the shorts they'll reach for again and again (so stock up while they're just $12). This style is available in six neutral colors, and they also come in big and tall sizes. </p></div></div><div class="FtN"><h3>10. A Black Tank</h3><div data-adroot class="ykW"><div class="PM_ mLa"><a class="wbj" target="_blank" rel="noopener noreferrer" href="https://oldnavy.gap.com/browse/product.do?pid=207419282"><span class="znc NEf"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/450504f5-f7d4-4127-9b12-f9ec1474bc29-screen-shot-2020-05-20-at-11621-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/450504f5-f7d4-4127-9b12-f9ec1474bc29-screen-shot-2020-05-20-at-11621-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 414w, https://imgix.bustle.com/uploads/image/2020/5/20/450504f5-f7d4-4127-9b12-f9ec1474bc29-screen-shot-2020-05-20-at-11621-pm.png?w=414&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 828w, https://imgix.bustle.com/uploads/image/2020/5/20/450504f5-f7d4-4127-9b12-f9ec1474bc29-screen-shot-2020-05-20-at-11621-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 450w, https://imgix.bustle.com/uploads/image/2020/5/20/450504f5-f7d4-4127-9b12-f9ec1474bc29-screen-shot-2020-05-20-at-11621-pm.png?w=450&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 900w" sizes="(min-width:768px) 450px, 414px" alt class="Eds" /></noscript></div></span><div class="_dN"><div class="bQJ tZD"><div><span><div class="nLD tRj">Slim-Fit Rib-Knit Tank</div></span></div><div class="lVd"><span>Old Navy</span><span> | </span><div><div class="BmB xQv">$10</div><div class="BmB">$5</div></div></div><p class="MDt">Available In Sizes XS-XXL</p><button class="pAJ ETQ aYf">see on old navy</button></div></div></a></div><p>There's a lot to be said about the humble tank. You can layer it, tuck into high-waisted jeans, or pair it with your favorite skirt. Plus, for less than the cost of a fancy iced coffee, you might as well buy one in every color.</p></div></div></div></div></article><aside class="fsd"><div class="yUH"><div class="lMQ"><h3 class="zem">More like this</h3><div class="Fjb"><a class="vVv" href="/p/targets-memorial-day-sale-includes-bogo-swimwear-for-the-whole-family-22918643"><div class="OOM"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/0347c4d0-5e20-40ea-8e33-a9ab79b30fd5-unicorn.png?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/0347c4d0-5e20-40ea-8e33-a9ab79b30fd5-unicorn.png?w=100&amp;h=100&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 100w, https://imgix.bustle.com/uploads/image/2020/5/20/0347c4d0-5e20-40ea-8e33-a9ab79b30fd5-unicorn.png?w=100&amp;h=100&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 200w, https://imgix.bustle.com/uploads/image/2020/5/20/0347c4d0-5e20-40ea-8e33-a9ab79b30fd5-unicorn.png?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 120w, https://imgix.bustle.com/uploads/image/2020/5/20/0347c4d0-5e20-40ea-8e33-a9ab79b30fd5-unicorn.png?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 240w" sizes="(min-width:768px) 120px, 100px" alt class="Eds dny" /></noscript></div></div><div class="MOw"><h2 class="DlL">Target's Memorial Day Sale Includes BOGO Swimwear For The Whole Family</h2><div class="bTp"><span>By </span><span class="wTG">Kinsey Gidick</span></div></div></a><a class="vVv" href="/p/carters-memorial-day-sale-is-here-tons-of-summer-essentials-are-50-off-22919143"><div class="OOM"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/20/27864ece-53d5-4402-9553-d4f90e4e1284-screen-shot-2020-05-20-at-114220-am.png?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/20/27864ece-53d5-4402-9553-d4f90e4e1284-screen-shot-2020-05-20-at-114220-am.png?w=100&amp;h=100&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 100w, https://imgix.bustle.com/uploads/image/2020/5/20/27864ece-53d5-4402-9553-d4f90e4e1284-screen-shot-2020-05-20-at-114220-am.png?w=100&amp;h=100&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 200w, https://imgix.bustle.com/uploads/image/2020/5/20/27864ece-53d5-4402-9553-d4f90e4e1284-screen-shot-2020-05-20-at-114220-am.png?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 120w, https://imgix.bustle.com/uploads/image/2020/5/20/27864ece-53d5-4402-9553-d4f90e4e1284-screen-shot-2020-05-20-at-114220-am.png?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 240w" sizes="(min-width:768px) 120px, 100px" alt class="Eds dny" /></noscript></div></div><div class="MOw"><h2 class="DlL">Carter's Memorial Day Sale Is Here &amp; Tons Of Summer Essentials Are 50% Off</h2><div class="bTp"><span>By </span><span class="wTG">Grace Gallagher</span></div></div></a><a class="vVv" href="/p/the-tommee-tippee-discount-for-mothers-day-is-the-perfect-way-to-celebrate-22883260"><div class="OOM"><div class="eZr"><noscript><img src="https://imgix.bustle.com/uploads/image/2020/5/7/9b091215-b2c2-4d69-9c30-70c287981911-0h4a1942-bottle-feeding-1.jpg?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70" srcSet="https://imgix.bustle.com/uploads/image/2020/5/7/9b091215-b2c2-4d69-9c30-70c287981911-0h4a1942-bottle-feeding-1.jpg?w=100&amp;h=100&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 100w, https://imgix.bustle.com/uploads/image/2020/5/7/9b091215-b2c2-4d69-9c30-70c287981911-0h4a1942-bottle-feeding-1.jpg?w=100&amp;h=100&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 200w, https://imgix.bustle.com/uploads/image/2020/5/7/9b091215-b2c2-4d69-9c30-70c287981911-0h4a1942-bottle-feeding-1.jpg?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70 120w, https://imgix.bustle.com/uploads/image/2020/5/7/9b091215-b2c2-4d69-9c30-70c287981911-0h4a1942-bottle-feeding-1.jpg?w=120&amp;h=120&amp;fit=crop&amp;crop=faces&amp;auto=format%2Ccompress&amp;cs=srgb&amp;q=70&amp;dpr=2 240w" sizes="(min-width:768px) 120px, 100px" alt class="Eds dny" /></noscript></div></div><div class="MOw"><h2 class="DlL">The Tommee Tippee Discount For Mother's Day Is The Perfect Way To Celebrate</h2><div class="bTp"><span>By </span><span class="wTG">Ellen Schmidt</span></div></div></a></div></div><div class="lMQ"><h3 class="zem eCm">Stay up to date</h3><div class="Bsv"><h2 class="oHg">Looking for more? Sign up for our weekly newsletter.</h2><form action="https://newsletter.bustle.com/signup" method="get"><input name="site" type="hidden" value="ROMPER" /><input name="source" type="hidden" /><div class="gaj"><input placeholder="Email address..." autocomplete="email" name="email" type="email" class="Vpg" required /><button class="pAJ ETQ qrj" type="submit">Sign up</button></div></form></div></div></div></aside><div class="PwM hrl"></div></div><div class="JqV"><input id="navCheckbox" type="checkbox" class="wps" /><label for="navCheckbox" class="Ujz"></label><nav class="zwX"><label for="navCheckbox" class="BxC"><button aria-label="close" class="Yts"></button></label><ul class="bdE"><li class="Wwa"><a href="/pregnancy">Pregnancy</a></li><li class="Wwa"><a href="/motherhood">Motherhood</a></li><li class="Wwa"><a href="/baby">Baby</a></li><li class="Wwa"><a href="/toddler">Toddler</a></li><li class="Wwa"><a href="/kid">Kid</a></li><li class="Wwa"><a href="/health-wellness-month">Health</a></li><li class="Wwa"><a href="/take-care">Take Care</a></li><li class="Wwa"><a href="/food">Food</a></li><li class="Wwa"><a href="/news">News</a></li><li class="Wwa"><a href="/entertainment">Entertainment</a></li><li class="Wwa"><a href="/sex-relationships">Sex &amp; Relationships</a></li><li class="Wwa"><a href="/fashion-beauty">Fashion &amp; Beauty</a></li><li><div class="JMA"></div></li><li><a href="https://bustle.company/" target="_blank" rel="noopener noreferrer">About Us</a></li><li><a href="/contact">Contact</a></li><li><a href="/newsletter">Newsletter</a></li><li><a href="/terms">Terms</a></li><li><a href="/privacy">Privacy</a></li><li><div class="SVT"><a href="https://www.facebook.com/Romperdotcom/" title="Facebook" target="_blank" rel="noopener noreferrer" class="eaq"><i class="MQj"></i></a><a href="https://twitter.com/romper" title="Twitter" target="_blank" rel="noopener noreferrer" class="eaq"><i class="PGz"></i></a><a href="https://www.pinterest.com/romperdotcom/" title="Pinterest" target="_blank" rel="noopener noreferrer" class="eaq"><i class="JNN"></i></a><a href="https://instagram.com/romper/" title="Instagram" target="_blank" rel="noopener noreferrer" class="eaq"><i class="wWk"></i></a></div></li><li><div class="ftR"></div></li></ul></nav></div><noscript data-noscript><img src="https://pixel.quantserve.com/pixel/p-xPmcrFNGfHkBg.gif" /><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=17519299&amp;cs_ucfr=0&amp;cv=2.0&amp;cj=1" /><img src="https://www.facebook.com/tr?id=932972280084675&amp;ev=PageView&amp;noscript=1" /></noscript></div><script>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</script><script>!(function(){for(var e=["Promise","Map","fetch","Object.assign","Array.prototype.includes"],t=0,n=e.length;t<n;t++)for(var r=e[t].split("."),o=0,i=r.length,a=window;o<i;o++)if(!(a=a[r[o]]))return document.write('<script defer src="https://polyfill.io/v3/polyfill.js?features='+e.join()+'"><\/script>')}())</script><script defer src="https://cdn2.bustle.com/romper/2020/common-31a289e806.js"></script><script defer src="https://cdn2.bustle.com/romper/2020/main-6c6ae4e123.js"></script><script defer src="https://cdn2.bustle.com/romper/2020/vendors-78bded0d9b.js"></script><script defer src="https://cdn2.bustle.com/romper/2020/ArticlePostPage-8b1a904f6c.js"></script></body></html>